Resolved
Our Engineering team has resolved the issue. EU systems may have had little to no impact during this outage.
Investigating
Our Engineering team is investigating degraded performance and inability to load app.eu.terraform.io. We will post updates with more information as it becomes available.